nixos-configuration/services/bookshelf.nix

22 lines
488 B
Nix

{ system, ... }:
let
bookshelf = builtins.getFlake
"github:jrpotter/bookshelf/bf9888c050b7a62f58be0198af19a6de7c40b375";
in
{
services.nginx = {
recommendedGzipSettings = true;
recommendedOptimisation = true;
recommendedProxySettings = true;
recommendedTlsSettings = true;
virtualHosts."bookshelf.jrpotter.com" = {
forceSSL = true;
enableACME = true;
locations."/" = {
root = bookshelf.packages.${system}.app;
};
};
};
}